본문으로 건너뛰기

E-mail 리턴, 반송 메세지 종류는 무엇인가요?

💡 요약 정리

  • 이메일 리턴 메시지는 12가지 주요 유형으로 분류됩니다.
  • Ctrl+F로 리턴메일에 나온 단어를 검색하여 원인을 빠르게 찾을 수 있습니다.
  • 각 에러 코드와 메시지를 통해 발송 실패 원인을 정확히 파악할 수 있습니다.
  • 대부분의 경우 상대방 메일서버 설정이나 받는사람의 메일 상태가 원인입니다.

1. 상대방 메일서버에 연결할 수 없을 때

에러 메시지:

  • 417 Temporary delivery error
  • The maximum number of delivery attempts has been reached
  • End of socket stream data

원인

DNS 질의를 통해 상대방 메일서버(MX record)를 찾았지만 메일서버에 접속할 수 없다는 의미입니다.

  • 상대방 메일서버가 동작중이 아닌 경우
  • 과도한 부하로 응답대기시간을 초과한 경우
  • 일시적인 네트워크 문제

해결 방법

상대방 메일서버의 관리자가 조치를 취하지 않으면 별도의 해결방법이 없습니다.

만약 대형포털 등 다른 메일서버에서 상대방 메일서버로 메일이 잘 들어간다면 다음 문제일 가능성이 있습니다:

네트워크 회선 문제

드물지만 일부 네트워크간에 속도가 아주 느려 문제가 발생하는 경우가 있습니다.

  • 메일서버가 설치된 네트워크와 다른 외부 네트워크 두 곳에서 상대방 메일서버의 25번 포트 응답속도를 비교
  • 응답속도가 현저하게 차이가 난다면 네트워크 관리업체에 문의

상대방 메일서버에서 별도의 조치를 취해둔 경우

드물지만 이 경우 상대방 메일서버 관리자에게 문의해야 합니다.

기타 관련 에러

Invalid server address

  • 받는사람의 도메인이 존재하지 않거나, 상대방 메일서버의 DNS 설정상의 문제
  • 주로 사용자가 받는사람의 도메인을 잘못 입력한 경우

Bad server response

  • 메일서버에서 인식할 수 없는 응답코드
  • 주로 IP가 차단된 경우

2. 받는사람이 존재하지 않는 경우

에러 메시지:

  • 550 User unknown
  • 550 Mailbox unavailable
  • 550 5.1.1 No such user
  • 554 delivery error: dd This user doesn't have a yahoo.co.kr account (userid@domain.com) [-5] - mta114.mail.krs.yahoo.com

원인

상대방 메일서버에 받는사람이 존재하지 않습니다.

해결 방법

  1. 메일주소를 다시 확인
  2. 다른 메일서버에서 보냈을 때 실제로 존재하는 유저라면 메일서버 설정 문제일 수 있음

3. 받는사람이 사용중지된 경우

에러 메시지:

  • 550 Account disabled
  • 550 5.1.1 Inactive mbox
  • 550 5.1.1 Suspended user
  • 554 delivery error: dd Sorry your message to userid@domain.com cannot be delivered. This account has been disabled or discontinued [#102]. - mta115.mail.krs.yahoo.com

원인

상대방 메일서버에서 받는사람이 사용중지/휴면계정으로 처리된 상태입니다.

해결 방법

받는사람에게 다른 방법으로 연락하여 계정 상태를 확인받아야 합니다.


4. 받는사람의 메일용량이 초과된 경우

에러 메시지:

  • 552 Requested mail action aborted: exceeded storage allocation
  • The recipient's mailbox is full

원인

상대방 메일서버에서 받는사람의 메일저장용량이 초과되었습니다.

해결 방법

  1. 잠시 후 다시 시도
  2. 받는사람에게 다른 방법으로 연락하여 메일함 정리 요청

5. 받는사람의 스팸설정(수신거부)에 의해 차단된 경우

에러 메시지:

  • 550 You are registered as spammer (by user's reject list)
  • 554 5.0.0 Service unavailable (userid: mail is denied, by spam filter)

원인

받는사람이 스팸설정 혹은 수신거부 목록에 보낸사람의 주소를 등록해두었을 가능성이 높습니다.

해결 방법

받는사람에게 다른 방법으로 연락하여 수신거부 목록 해제 요청


6. 메일발송권한이 없거나 상대방 메일서버 설정 문제

에러 메시지:

  • 550 Relay denied
  • 554 Relay operation rejected
  • 550 5.7.1 Unable to relay for userid@domain.com

원인 및 해결방법

같은 도메인을 제외한 다른 모든 메일서버에서 에러가 발생한 경우

사용자의 메일클라이언트(아웃룩 등) 설정 문제일 가능성이 높습니다.

  • 계정 설정 시 [보내는 메일서버에 인증 필요] 옵션을 체크했는지 확인

특정 메일서버에서만 에러가 발생할 경우

상대방 메일서버에서 DNS 설정 혹은 메일서버의 설정 오류로 인해 발생한 문제입니다.

  • 상대방 메일서버의 관리자가 조치를 취하지 않으면 별도의 해결방법이 없음

7. 대량 메일 발송으로 인해 대형포털로부터 IP가 차단된 경우

에러 메시지:

  • 550 5.7.1 ... Error.your access was denied.? Since you sent too many e-mails,you are not allowed to send more e-mails within 24 hours.After 24 hours,you can send e-mails as usual.
  • 421 4.3.2 Your IP(111.112.113.114) is filtered and this connection will be closed. You must register your IP to http://realip.naver.com
  • 421 4.3.1 You send too many messages.
  • 5.1.0 - Unknown address error 550-'Transaction failed. (SPAM_SUSPECT:IP_CONTROL) (http://cleanip.paran.com)'
  • 451 mta113.mail.krs.yahoo.com Resources temporarily unavailable. Please try again later [#4.16.5].

원인

대형포털의 경우 IP를 등록해두지 않고 1일 1,000통(시간당 100통) 이상의 대량 메일을 보내면 IP가 차단될 가능성이 있습니다.

포털별 대응 방법

다음(Daum)

error) 550 5.7.1 ... Error.your access was denied.? Since you sent too many e-mails,you are not allowed
to send more e-mails within 24 hours.After 24 hours,you can send e-mails as usual.
If you did not send any e-mails,which is considered as a spam,you'd better register
  • 24시간 대기 후 재발송
  • IP 등록 권장

네이버(Naver)

error) 421 4.3.2 Your IP(111.112.113.114) is filtered and this connection will be closed.
You must register your IP to http://realip.naver.com

네이트(Nate)

error) 421 4.3.1 You send too many messages.
  • 발송량 조절 필요

파란(Paran)

error) 5.1.0 - Unknown address error 550-'Transaction failed. (SPAM_SUSPECT:IP_CONTROL)
(http://cleanip.paran.com)'

야후(Yahoo)

error) 451 mta113.mail.krs.yahoo.com Resources temporarily unavailable. Please try again later [#4.16.5].
  • 일시적 제한, 재시도 필요

8. 상대방 메일서버에서 스팸으로 인식해서 차단된 경우

에러 메시지:

  • 553 Blocked for spam
  • 550 5.5.0 Your message was rejected.

원인

상대방 메일서버에서 스팸으로 인식하여 거부한 것으로 추측됩니다.

거부한 원인에 대해 언급되어 있지 않으므로 어떤 조건에 의해 거부되었는지 리턴메일만으로는 알 수 없습니다.

해결 방법

  1. 제목이나 본문 내에 광고, 성인 등 스팸으로 분류될만한 단어가 있는지 확인
  2. 해결이 안될 경우 상대방 메일서버의 관리자에게 문의

9. 상대방 메일서버에서 바이러스로 인식해서 차단된 경우

에러 메시지:

  • 550 Virus in your mail!!!

원인

상대방 메일서버가 메일 내에 바이러스를 검출하여 차단한 경우입니다.

주의사항

실제 바이러스 메일을 보내지 않았더라도 "보낸 사람" 주소가 위조되어 잘못된 리턴메일을 받는 경우가 있습니다.

이는 스팸 발송자들이 임의의 주소를 보낸 사람으로 설정하여 발송하기 때문이며, 이 경우 무시하시면 됩니다.


10. 첨부파일에 실행파일을 첨부할 수 없는 경우 (Gmail)

에러 메시지:

  • 552 5.7.0 Illegal Attachment 36si248323nzk+I9:I15

원인

Gmail의 경우 바이러스 차단을 위해 첨부 파일에 실행 파일이 들어간 경우까지 모두 차단하고 있습니다.

해결 방법

  • 실행파일을 압축해서 보내더라도 동일하게 차단됨
  • 꼭 보내야 한다면 실행파일의 확장자를 다른 것으로 변경하는 방법만 가능
  • 파일 공유 서비스(클라우드 스토리지) 활용 권장

11. 받는사람과 보낸사람에 문제가 있어 리턴메일이 반복되는 경우

에러 메시지:

  • Mail loop detected

원인

메일링, 서버 내 서비스 안내메일 등 자동툴을 통해 메일을 보낼 때 많이 발생하는 문제입니다.

메일을 보낸 주소와 받는 주소가 모두 잘못되었을 때 반복적으로 송수신이 일어나며, 서버부하를 방지하기 위해 자동 차단됩니다.

해결 방법

메일링 서비스 시 다음 사항에 유의:

  1. 보낸사람의 주소가 실제로 존재하는지, 메일을 받을 수 있는 상태인지 확인
  2. 보낸사람의 메일계정 용량이 리턴메일을 받을 수 있을만큼 충분한지 확인

12. 받는 메일서버에서 허용하는 최대메일크기를 초과한 경우

에러 메시지:

  • Message size excedes the server limit

원인

대부분의 메일서버에서는 부하를 방지하기 위해 메일의 크기가 일정 크기 이상일 경우 받지 않도록 조치하고 있습니다.

일반적으로 첨부파일은 10MB 정도까지만 허용하고 있습니다.

해결 방법

  1. 첨부파일을 삭제해서 메일의 크기를 줄인 뒤 다시 발송
  2. 첨부파일은 다른 방법으로 전달:
    • 파일 공유 서비스 (네이버 클라우드, 구글 드라이브, Dropbox 등)
    • FTP 서버 활용
    • 파일 분할 압축 후 여러 번 발송

빠른 검색 팁

리턴메일을 받았을 때 Ctrl+F (또는 Mac에서 Cmd+F)를 눌러 리턴메일에 나온 에러 메시지의 키워드를 검색하면 해당하는 문제 유형을 빠르게 찾을 수 있습니다.


참고사항

  • 대부분의 리턴메일은 상대방 메일서버의 설정이나 받는사람의 메일 상태가 원인입니다.
  • 발송한 메일서버의 문제가 아닌 경우가 많으므로, 먼저 리턴메일의 에러 메시지를 정확히 확인하는 것이 중요합니다.
  • 지속적으로 같은 에러가 발생한다면 상대방에게 다른 연락 수단으로 문의하는 것이 가장 확실한 해결 방법입니다.